// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(http|ftp|https)://([^/\r\n]+)(/[^\r\n]*)?").unwrap();
let string = "http://www.radsoftware.com.au/web/
http://www.radsoftware.com.au/web/Default.aspx
https://www.radsoftware.com.au
http://www.radsoftware.com.au/web/CodeZone/Default.aspx?from=RegexDesigner";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}