import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|ftp|https)://([^/\\r\\n]+)(/[^\\r\\n]*)?";
final String string = "http://www.radsoftware.com.au/web/\n"
+ "http://www.radsoftware.com.au/web/Default.aspx\n"
+ "https://www.radsoftware.com.au\n"
+ "http://www.radsoftware.com.au/web/CodeZone/Default.aspx?from=RegexDesigner";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}