#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/([-a-z0-9.]*\.)?linkedin\.com\/.*$"
Local $sString = "# correct LinkedIn URLs" & @CRLF & _
"https://linkedin.com/some_profile" & @CRLF & _
"https://www.linkedin.com/some_profile" & @CRLF & _
"" & @CRLF & _
"# optional dot exploit, #1" & @CRLF & _
"https://notmylinkedin.com/" & @CRLF & _
"" & @CRLF & _
"# escaping exploit, #2" & @CRLF & _
"https://notmylinkedin.com?.linkedin.com/" & @CRLF & _
"https://notmylinkedin.com#.linkedin.com/" & @CRLF & _
"https://notmylinkedin.com/.linkedin.com/" & @CRLF & _
"" & @CRLF & _
"# subdomain exploit, #1" & @CRLF & _
"https://linkedin.com.notmylinkedin.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")