import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/([-a-z0-9.]*\\.)?linkedin\\.com\\/.*$";
final String string = "# correct LinkedIn URLs\n"
+ "https://linkedin.com/some_profile\n"
+ "https://www.linkedin.com/some_profile\n\n"
+ "# optional dot exploit, #1\n"
+ "https://notmylinkedin.com/\n\n"
+ "# escaping exploit, #2\n"
+ "https://notmylinkedin.com?.linkedin.com/\n"
+ "https://notmylinkedin.com#.linkedin.com/\n"
+ "https://notmylinkedin.com/.linkedin.com/\n\n"
+ "# subdomain exploit, #1\n"
+ "https://linkedin.com.notmylinkedin.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}