import re
regex = re.compile(r"^https?:\/\/([-a-z0-9.]*\.)?linkedin\.com\/.*$", flags=re.MULTILINE)
test_str = ("# correct LinkedIn URLs\n"
"https://linkedin.com/some_profile\n"
"https://www.linkedin.com/some_profile\n\n"
"# optional dot exploit, #1\n"
"https://notmylinkedin.com/\n\n"
"# escaping exploit, #2\n"
"https://notmylinkedin.com?.linkedin.com/\n"
"https://notmylinkedin.com#.linkedin.com/\n"
"https://notmylinkedin.com/.linkedin.com/\n\n"
"# subdomain exploit, #1\n"
"https://linkedin.com.notmylinkedin.com/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")