package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/([-a-z0-9.]*\.)?linkedin\.com\/.*$`)
var str = `# correct LinkedIn URLs
https://linkedin.com/some_profile
https://www.linkedin.com/some_profile
# optional dot exploit, #1
https://notmylinkedin.com/
# escaping exploit, #2
https://notmylinkedin.com?.linkedin.com/
https://notmylinkedin.com#.linkedin.com/
https://notmylinkedin.com/.linkedin.com/
# subdomain exploit, #1
https://linkedin.com.notmylinkedin.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}