using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/([-a-z0-9.]*\.)?linkedin\.com\/.*$";
string input = @"# correct LinkedIn URLs
https://linkedin.com/some_profile
https://www.linkedin.com/some_profile
# optional dot exploit, #1
https://notmylinkedin.com/
# escaping exploit, #2
https://notmylinkedin.com?.linkedin.com/
https://notmylinkedin.com#.linkedin.com/
https://notmylinkedin.com/.linkedin.com/
# subdomain exploit, #1
https://linkedin.com.notmylinkedin.com/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}