use strict;
my $str = '# correct LinkedIn URLs
https://linkedin.com/some_profile
https://www.linkedin.com/some_profile
# optional dot exploit, #1
https://notmylinkedin.com/
# escaping exploit, #2
https://notmylinkedin.com?.linkedin.com/
https://notmylinkedin.com#.linkedin.com/
https://notmylinkedin.com/.linkedin.com/
# subdomain exploit, #1
https://linkedin.com.notmylinkedin.com/';
my $regex = qr/^https?:\/\/([-a-z0-9.]*\.)?linkedin\.com\/.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}