const regex = /^https?:\/\/([-a-z0-9.]*\.)?linkedin\.com\/.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/([-a-z0-9.]*\\.)?linkedin\\.com\\\/.*$', 'gm')
const str = `# correct LinkedIn URLs
https://linkedin.com/some_profile
https://www.linkedin.com/some_profile
# optional dot exploit, #1
https://notmylinkedin.com/
# escaping exploit, #2
https://notmylinkedin.com?.linkedin.com/
https://notmylinkedin.com#.linkedin.com/
https://notmylinkedin.com/.linkedin.com/
# subdomain exploit, #1
https://linkedin.com.notmylinkedin.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}