package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:\b\w+?\b\s*){0,3})[dD]ata((?:\s*\b\w+?\b){0,3})`)
var str = ` Data is very important in in in to use because data jfsdl fjdskjf asdkfj adlfj...
test ets tets tet We value data since we need it ...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}