import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\b\\w+?\\b\\s*){0,3})[dD]ata((?:\\s*\\b\\w+?\\b){0,3})";
final String string = " Data is very important in in in to use because data jfsdl fjdskjf asdkfj adlfj... \n"
+ " test ets tets tet We value data since we need it ...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}