// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:\b\w+?\b\s*){0,3})[dD]ata((?:\s*\b\w+?\b){0,3})").unwrap();
let string = " Data is very important in in in to use because data jfsdl fjdskjf asdkfj adlfj...
test ets tets tet We value data since we need it ...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}