re = /((?:\b\w+?\b\s*){0,3})[dD]ata((?:\s*\b\w+?\b){0,3})/
str = ' Data is very important in in in to use because data jfsdl fjdskjf asdkfj adlfj...
test ets tets tet We value data since we need it ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end