$re = '/((?:\b\w+?\b\s*){0,3})[dD]ata((?:\s*\b\w+?\b){0,3})/';
$str = ' Data is very important in in in to use because data jfsdl fjdskjf asdkfj adlfj...
test ets tets tet We value data since we need it ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);