import re
regex = re.compile(r"((?:\b\w+?\b\s*){0,3})[dD]ata((?:\s*\b\w+?\b){0,3})")
test_str = (" Data is very important in in in to use because data jfsdl fjdskjf asdkfj adlfj... \n"
" test ets tets tet We value data since we need it ...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")