use strict;
my $str = ' Data is very important in in in to use because data jfsdl fjdskjf asdkfj adlfj...
test ets tets tet We value data since we need it ...';
my $regex = qr/((?:\b\w+?\b\s*){0,3})[dD]ata((?:\s*\b\w+?\b){0,3})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}