# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|\[)[^][.]*\K\.//gm;t' <<< "[city.name][city.state][city.mayor][city.mayor.name](city.name)"