const regex = /(?:\G(?!^)|\[)[^][.]*\K\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|\\[)[^][.]*\\K\\.', 'gm')
const str = `[city.name][city.state][city.mayor][city.mayor.name](city.name)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);