use strict;
my $str = '[city.name][city.state][city.mayor][city.mayor.name](city.name)';
my $regex = qr/(?:\G(?!^)|\[)[^][.]*\K\./mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";