import re
regex = re.compile(r"(?:\G(?!^)|\[)[^][.]*\K\.", flags=re.MULTILINE)
test_str = "[city.name][city.state][city.mayor][city.mayor.name](city.name)"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)