using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|\[)[^][.]*\K\.";
string substitution = @"";
string input = @"[city.name][city.state][city.mayor][city.mayor.name](city.name)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}