$re = '/(?:\G(?!^)|\[)[^][.]*\K\./m';
$str = '[city.name][city.state][city.mayor][city.mayor.name](city.name)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;