import Foundation
let pattern = #"(?:\G(?!^)|\[)[^][.]*\K\."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[city.name][city.state][city.mayor][city.mayor.name](city.name)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)