using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^)(?<!\. )[A-Z][a-z]+";
string substitution = @"";
string input = @"This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}