import Foundation
let pattern = #"(?<!^)(?<!\. )[A-Z][a-z]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)