re = /(?<!^)(?<!\. )[A-Z][a-z]+/m
str = 'This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence.
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result