import re
regex = re.compile(r"(?<!^)(?<!\. )[A-Z][a-z]+", flags=re.MULTILINE)
test_str = ("This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence.\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)