const regex = new RegExp('(?<!^)(?<!\\. )[A-Z][a-z]+', 'gm')
const str = `This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence.
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);