use strict;
my $str = 'This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence.
';
my $regex = qr/(?<!^)(?<!\. )[A-Z][a-z]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";