#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^a0\r\n]$|^[^0\r\n]+[^a\r\n]+$"
Local $sString = "a" & @CRLF & _
"0" & @CRLF & _
"aa" & @CRLF & _
"00" & @CRLF & _
"0a" & @CRLF & _
"a0" & @CRLF & _
"1" & @CRLF & _
"b" & @CRLF & _
"0b" & @CRLF & _
"1a" & @CRLF & _
"0bb" & @CRLF & _
"11a" & @CRLF & _
"a1" & @CRLF & _
"b0" & @CRLF & _
"b0njour" & @CRLF & _
"b0njour a" & @CRLF & _
"b0njour a toi" & @CRLF & _
"attention divisé par 0" & @CRLF & _
"est zéro" & @CRLF & _
"0 est zéro" & @CRLF & _
"0+a" & @CRLF & _
"1+b" & @CRLF & _
"c0uc0u" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")