// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^a0\r\n]$|^[^0\r\n]+[^a\r\n]+$").unwrap();
let string = "a
0
aa
00
0a
a0
1
b
0b
1a
0bb
11a
a1
b0
b0njour
b0njour a
b0njour a toi
attention divisé par 0
est zéro
0 est zéro
0+a
1+b
c0uc0u
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}