use strict;
my $str = 'a
0
aa
00
0a
a0
1
b
0b
1a
0bb
11a
a1
b0
b0njour
b0njour a
b0njour a toi
attention divisé par 0
est zéro
0 est zéro
0+a
1+b
c0uc0u
';
my $regex = qr/^[^a0\r\n]$|^[^0\r\n]+[^a\r\n]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}