using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^a0\r\n]$|^[^0\r\n]+[^a\r\n]+$";
string input = @"a
0
aa
00
0a
a0
1
b
0b
1a
0bb
11a
a1
b0
b0njour
b0njour a
b0njour a toi
attention divisé par 0
est zéro
0 est zéro
0+a
1+b
c0uc0u
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}