package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^a0\r\n]$|^[^0\r\n]+[^a\r\n]+$`)
var str = `a
0
aa
00
0a
a0
1
b
0b
1a
0bb
11a
a1
b0
b0njour
b0njour a
b0njour a toi
attention divisé par 0
est zéro
0 est zéro
0+a
1+b
c0uc0u
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}