import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^a0\\r\\n]$|^[^0\\r\\n]+[^a\\r\\n]+$";
final String string = "a\n"
+ "0\n"
+ "aa\n"
+ "00\n"
+ "0a\n"
+ "a0\n"
+ "1\n"
+ "b\n"
+ "0b\n"
+ "1a\n"
+ "0bb\n"
+ "11a\n"
+ "a1\n"
+ "b0\n"
+ "b0njour\n"
+ "b0njour a\n"
+ "b0njour a toi\n"
+ "attention divisé par 0\n"
+ "est zéro\n"
+ "0 est zéro\n"
+ "0+a\n"
+ "1+b\n"
+ "c0uc0u\n\n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}