# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^a0\r\n]$|^[^0\r\n]+[^a\r\n]+$"
test_str = ("a\n"
"0\n"
"aa\n"
"00\n"
"0a\n"
"a0\n"
"1\n"
"b\n"
"0b\n"
"1a\n"
"0bb\n"
"11a\n"
"a1\n"
"b0\n"
"b0njour\n"
"b0njour a\n"
"b0njour a toi\n"
"attention divisé par 0\n"
"est zéro\n"
"0 est zéro\n"
"0+a\n"
"1+b\n"
"c0uc0u\n\n"
" \n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.