const regex = /^[^a0\r\n]$|^[^0\r\n]+[^a\r\n]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^a0\\r\\n]$|^[^0\\r\\n]+[^a\\r\\n]+$', 'gm')
const str = `a
0
aa
00
0a
a0
1
b
0b
1a
0bb
11a
a1
b0
b0njour
b0njour a
b0njour a toi
attention divisé par 0
est zéro
0 est zéro
0+a
1+b
c0uc0u
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}