# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S|^)\n(?!\n)/$1[replacement]/g;t' <<< "
this is a
this is b
this is c
d
test
test
test
test
"