const regex = /(\S|^)\n(?!\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S|^)\\n(?!\\n)', 'g')
const str = `
this is a
this is b
this is c
d
test
test
test
test
`;
const subst = `$1[replacement]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);