re = /(\S|^)\n(?!\n)/
str = '
this is a
this is b
this is c
d
test
test
test
test
'
subst = '$1[replacement]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result