import Foundation
let pattern = #"(\S|^)\n(?!\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
this is a
this is b
this is c
d
test
test
test
test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1[replacement]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)