use strict;
my $str = '
this is a
this is b
this is c
d
test
test
test
test
';
my $regex = qr/(\S|^)\n(?!\n)/p;
my $subst = '$1[replacement]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";