$re = '/(\S|^)\n(?!\n)/';
$str = '
this is a
this is b
this is c
d
test
test
test
test
';
$subst = "$1[replacement]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;