#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\S|^)\n(?!\n)"
Local $sString = "" & @CRLF & _
"this is a" & @CRLF & _
"this is b" & @CRLF & _
"this is c" & @CRLF & _
"" & @CRLF & _
"d" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"test" & @CRLF & _
""
Local $sSubst = "$1[replacement]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)