#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([a-z0-9])([A-Z])"
Local $sString = "UsersGroupedByRegistrationMonthYear.csv"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)