package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z0-9])([A-Z])`)
var str = `UsersGroupedByRegistrationMonthYear.csv`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}