const regex = /([a-z0-9])([A-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z0-9])([A-Z])', 'g')
const str = `UsersGroupedByRegistrationMonthYear.csv`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);