$re = '/([a-z0-9])([A-Z])/';
$str = 'UsersGroupedByRegistrationMonthYear.csv';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;