import Foundation
let pattern = #"([a-z0-9])([A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"UsersGroupedByRegistrationMonthYear.csv"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)