using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z0-9])([A-Z])";
string substitution = @"$1 $2";
string input = @"UsersGroupedByRegistrationMonthYear.csv";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}